查看: 418|回复: 6

[已解答] 关于Arduino IDE升级到1.8.10后Blinker库编译失败的问题

[复制链接]
发表于 2019-11-21 16:25 | 显示全部楼层 |阅读模式
  最近看到arduino官方ide升级到1.8.10后我就去把ide更新了以下,更新后发现编译blinker的库中的样例时报错,报错全部是因为blinker库中的文件#include找不到esp8266库文件。(比如说:在blinker库的WebSockets.h中#include <ESP8266WiFi.h>,就会找不到ESP8266库的ESP8266WiFi.h文件)以前都没报过错。而且我也是按照blinker官方文档的步骤把库文件放到指定目录的。后来试了好多次路径都没解决,于是最后把arduino ide换回1.8.9问题就没了。ide版本不知道更新了什么会出这个问题,是否也有人和我一样。现在还不知道原因。
发表于 2019-11-21 16:50 | 显示全部楼层
我这边1.8.10使用正常
发表于 2019-11-23 23:10 | 显示全部楼层
IDE -->include library -->blinker 会报错,然后删除。
在文档library下,启动git bash输入:git clone https://github.com/blinker-iot/blinker-library.git
下载完成后,修改文件名称就没有报错了。
发表于 2019-12-6 23:21 | 显示全部楼层
topdog 发表于 2019-11-23 23:10
IDE -->include library -->blinker 会报错,然后删除。
在文档library下,启动git bash输入:git clone ht ...

老哥,这怎么操作啊,什么意思 啊

点评

直接按照blinker文档下载即可  详情 回复 发表于 2019-12-7 10:46
发表于 2019-12-7 10:46 | 显示全部楼层
陈帅帅儿 发表于 2019-12-6 23:21
老哥,这怎么操作啊,什么意思 啊

直接按照blinker文档下载即可
发表于 2019-12-7 15:07 | 显示全部楼层
奈何col 发表于 2019-12-7 10:46
直接按照blinker文档下载即可

不行的,他那个blinker库编译不了,一直报错

点评

可以肯定是你没操作对,删除已经安装的库,然后按文档操作  详情 回复 发表于 2019-12-7 19:10
发表于 2019-12-7 19:10 | 显示全部楼层
陈帅帅儿 发表于 2019-12-7 15:07
不行的,他那个blinker库编译不了,一直报错

可以肯定是你没操作对,删除已经安装的库,然后按文档操作
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

热门推荐

Blynk与m5stack basic以及uiflow的交互玩法
Blynk与m5stack basic以及
Blynk与m5stack basic以及uiflow的交互玩法 [准备工作我们假设玩家已经熟悉下面的准备
【搬运】通过UDP将M5Camera图像发送至M5Stack
【搬运】通过UDP将M5Camer
本例将介绍通过UDP发送图像至M5Stack,代码分为M5CameraB与M5Stack,由于UDP传输
SYN6288语音模块
SYN6288语音模块
我用arduino写SYN6288的程序,用的是UNO板,可以吗? SYN怎么将文字转化为语音输出啊
【原创】 drawbot平面关节scara机械臂写字机 画画机器人直播...
【原创】 drawbot平面关节
这个项目上个月就在做了,结构和代码反反复复改了多次,加上自己又太忙,一直没来得及
【原创】全球最小口袋3D打印机mini one直播教程贴
【原创】全球最小口袋3D打
最近闲得蛋疼,没事搞个掌上3D打印机,先放效果图吧。 搞了半天,终于能正常打印,
Copyright   ©2015-2016  Arduino中文社区  Powered by©Discuz!   
快速回复 返回顶部 返回列表